Note: The other languages of the website are Google-translated. Back to English

¿Cómo encontrar valor en una celda con una lista separada por comas en Excel?

Suponiendo que tiene una columna que contiene valores separados por comas, como Ventas, 123, AAA, y ahora desea encontrar el valor 123 en la celda separada por comas, ¿cómo puede hacerlo? Este artículo presentará un método para resolver el problema.

Encuentre valor en una celda con una lista separada por comas con fórmula


Encuentre valor en una celda con una lista separada por comas con fórmula

La siguiente fórmula puede ayudarlo a encontrar valor en una celda con una lista separada por comas en Excel. Haz lo siguiente.

1. Seleccione una celda en blanco, ingrese la fórmula =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") en la barra de fórmulas y luego presione la tecla Enter. Ver captura de pantalla:

Nota:: en la fórmula, A2 es la celda que contiene los valores separados por comas que encontrará.

2. Siga seleccionando la celda de resultados y arrastre el controlador de relleno hacia abajo para obtener todos los resultados. Si el valor "123" está en las celdas separadas por comas, obtendrá el resultado como "Sí"; de lo contrario, obtendrá el resultado como "No". Ver captura de pantalla:


Artículos relacionados:


Las mejores herramientas de productividad de oficina

Kutools para Excel resuelve la mayoría de sus problemas y aumenta su productividad en un 80%

  • Reutilizar: Inserte rápidamente fórmulas complejas, gráficos y cualquier cosa que hayas usado antes; Cifrar celdas con contraseña; Crear lista de distribución y enviar correos electrónicos ...
  • Barra de súper fórmula (edite fácilmente varias líneas de texto y fórmulas); Diseño de lectura (leer y editar fácilmente un gran número de celdas); Pegar en rango filtrado...
  • Combinar celdas / filas / columnas sin perder datos; Contenido de celdas divididas; Combinar filas / columnas duplicadas... Prevenir celdas duplicadas; Comparar rangos...
  • Seleccione Duplicado o Único Filas; Seleccionar filas en blanco (todas las celdas están vacías); Super Find y Fuzzy Find en muchos libros de trabajo; Selección aleatoria ...
  • Copia exacta Varias celdas sin cambiar la referencia de la fórmula; Crear referencias automáticamente a varias hojas; Insertar viñetas, Casillas de verificación y más ...
  • Extraer texto, Agregar texto, Eliminar por posición, Quitar espacio; Crear e imprimir subtotales de paginación; Convertir entre contenido de celdas y comentarios...
  • Súper filtro (guardar y aplicar esquemas de filtros a otras hojas); Orden avanzado por mes / semana / día, frecuencia y más; Filtro especial en negrita, cursiva ...
  • Combinar libros y hojas de trabajo; Combinar tablas basadas en columnas clave; Dividir datos en varias hojas; Conversión por lotes de xls, xlsx y PDF...
  • Más de 300 potentes funciones. Compatible con Office/Excel 2007-2021 y 365. Compatible con todos los idiomas. Fácil implementación en su empresa u organización. Funciones completas Prueba gratuita de 30 días. Garantía de devolución de dinero de 60 días.
pestaña kte 201905

Office Tab lleva la interfaz con pestañas a Office y hace que su trabajo sea mucho más fácil

  • Habilite la edición y lectura con pestañas en Word, Excel, PowerPoint, Publisher, Access, Visio y Project.
  • Abra y cree varios documentos en nuevas pestañas de la misma ventana, en lugar de en nuevas ventanas.
  • ¡Aumenta su productividad en un 50% y reduce cientos de clics del mouse todos los días!
officetab parte inferior
Comentarios (16)
Aún no hay calificaciones. ¡Sé el primero en calificar!
Este comentario fue minimizado por el moderador en el sitio
Buenos días a todos. Tengo una pregunta de Excel sobre cómo contar valores específicos separados por comas en una sola celda en Excel. Quiero contar no de 15 en una sola celda que contiene 15,215,15,155,45,1515,15 resultado 3. Hay alguna formula en excel.
Este comentario fue minimizado por el moderador en el sitio
Sí, hay una función en Excel que puede hacer esto por usted. Sin embargo, como se explica en el problema anterior, para obtener una mayor precisión de sus datos, agregue una coma a la izquierda y a la derecha de su lista e inclúyala en su búsqueda. Vea el ejemplo a continuación:
, 15,215,15,155,45,1515,15,
=CONTAR.SI(A1, ",15,")
La explicación de esta fórmula es la siguiente: =CONTAR.SI(número de celda o rango, valor que está buscando/contando)
Avíseme si necesita un mejor ejemplo.
Este comentario fue minimizado por el moderador en el sitio
Hola!
Esta es una fórmula realmente genial, pero tiene... ¿defecto? ... que no puedo averiguar cómo solucionarlo. "Defecto" no es la palabra correcta, pero no se me ocurre (son las 8:30 am del lunes) la palabra correcta.
Cuando busca cualquier parte de un número, obtiene "sí". Entonces, todos los siguientes devuelven "sí":
=SI(ESNUMERO(BÚSQUEDA(12,A2)),"sí","no")
=SI(ESNUMERO(BÚSQUEDA(23,A2)),"sí","no")
=SI(ESNUMERO(BÚSQUEDA(3,A2)),"sí","no")

Intenté envolver los números entre comillas sin éxito. La fórmula funciona perfectamente para el caso de uso del ejemplo, en el que todos los números tienen la misma longitud. Pero si está buscando un número más corto que aparece en la cadena, obtendrá un falso positivo.
¿Hay alguna alternativa a "BUSCAR" que sea más literal (nuevamente, es esa la palabra? jaja)? 
¡Gracias! 
Este comentario fue minimizado por el moderador en el sitio
Hola Scott S., ¿Te refieres a buscar la cadena exacta?
Este comentario fue minimizado por el moderador en el sitio
Hola, Cristal.
Sí, supongo que esa es la manera de expresarlo. 
La solución actual devolverá "Sí" para cualquier parte de la cadena de números. Entonces, los números 1, 2, 3, 12, 23 y 123 devolverán "Sí". 
He estado tratando de encontrar una solución que busque una cadena de números y devuelva "Sí" para una coincidencia exacta. 
Este comentario fue minimizado por el moderador en el sitio
Hola Scott S, gracias por tus comentarios. Todavía no he encontrado la solución y te responderé si la encuentro.
Este comentario fue minimizado por el moderador en el sitio
He encontrado una solución para esto. Si agrega una coma a la izquierda y a la derecha de su lista y las incluye (como un sándwich) en su búsqueda, le permitirá encontrar una coincidencia exacta. Ejemplo a continuación:
, 123,231,321,122,321,1,2,3,23,
BÚSQUEDA(",23,")
De esta manera, obliga a la búsqueda a coincidir de una coma a otra en lugar de solo una parte de la entrada de la lista. ¿Espero que esto sea lo que estabas buscando?
Este comentario fue minimizado por el moderador en el sitio
He encontrado una solución. Si agrega una coma a la izquierda y derecha de su lista, requerirá la función de búsqueda para encontrar una coincidencia exacta de coma a coma. Vea el ejemplo a continuación:
=SI(ESNUMERO(BÚSQUEDA(",12,"A2)),"sí","no")

, 312,123,10,112,126,
Esto devolverá falso porque no hay ninguna variable de coma a coma (,12,) que coincida con la búsqueda. 
Si necesita más aclaraciones, hágamelo saber y publicaré un mejor ejemplo. Estaba teniendo el mismo problema al automatizar un informe para mi jefe y tuve una epifanía. :)
Este comentario fue minimizado por el moderador en el sitio
Oye, todavía no puedo entender esto. Aún sigo teniendo el mismo problema. en lugar de usar el número en la fórmula, estoy usando una referencia de celda. por ejemplo, si estoy buscando "1"(Q$1) en (123, 25,29,200)(J2) me sigue dando SÍ. La fórmula es =SI(ESNÚMERO(BÚSQUEDA(Q$1,$J2)),"sí","no")

PD: tengo un gran conjunto de datos que no puedo poner comas antes y después en cada celda. Agradeceria una solucion
Este comentario fue minimizado por el moderador en el sitio
hola por favor ayuda

Tengo una tabla en Excel con dos columnas A y B, debajo de A hay un valor, por ejemplo, A2 Cell tiene 1,2,2,1,2,1,2, etc. (solo tiene dos números 1 y 2, pero necesita reconocer que solo tiene 1 y 2 en toda la celda y ningún otro número) y A3 tiene 1,1,1 y A4 tiene 0, A5 tiene 2,2,2,2 y A6 tiene 20. Quiero que B2 devuelva el valor para A2 como Asia , B3 África, B4 como Ninguno, B5 como América y B6 como Europa. Pensé que podría usar la fórmula if pero no es capaz de reconocer números separados por comas y valor de retorno). Por favor ayuda
Este comentario fue minimizado por el moderador en el sitio
Que tal esto por favor, necesito obtener los valores en A y equipararlos con las cifras en C y devolver los valores en B separados como en comas respectivamente a C.

Muchas Gracias
Este comentario fue minimizado por el moderador en el sitio
Hola duncan,
Si está utilizando Excel para 365, la siguiente fórmula puede ayudar a resolver el problema.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Esta fórmula solo funciona en Excel para 365. Para otras versiones de Excel que no sean Excel para 365, no he encontrado una fórmula que la maneje.
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Este comentario fue minimizado por el moderador en el sitio
Hola a todos, tengo un celular que tiene varios paises separados por comas
Ejemplo: el valor de la celda A2 es (India, Japón, Malasia, Gran China)
La columna G tiene los nombres de los países.
Ahora, necesito encontrar una fórmula que compare el valor de la columna G con el valor de la celda A2.
Si el valor coincide, devuelve verdadero; de lo contrario, devuelve falso
Este comentario fue minimizado por el moderador en el sitio
Hola Mohini Verma,
La fórmula se puede modificar de la siguiente manera:
=SI(ESNÚMERO(BUSCAR(G2,A2)),"VERDADERO","FALSO")
Este comentario fue minimizado por el moderador en el sitio
Oye, todavía no puedo entender esto. Aún sigo teniendo el mismo problema. en lugar de usar el número en la fórmula, estoy usando una referencia de celda. por ejemplo, si estoy buscando "1"(Q$1) en (123, 25,29,200)(J2) me sigue dando SÍ. La fórmula es =SI(ESNÚMERO(BÚSQUEDA(Q$1,$J2)),"sí","no")

PD: tengo un gran conjunto de datos que no puedo poner comas antes y después en cada celda. Agradeceria una solucion
Este comentario fue minimizado por el moderador en el sitio
hola hassam

Simplemente use la siguiente fórmula sin la función IF. Si el número coincide exactamente, obtendrá el resultado "VERDADERO", de lo contrario obtendrás el resultado"FALSO".
=ESNUMERO(ENCONTRAR(",1,","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
No hay comentarios publicados aquí todavía
Deje sus comentarios
Publicar como invitado
×
Califica esta publicación:
0   Personajes
Ubicaciones sugeridas

Seguinos

Copyright © 2009 - www.extendoffice.com. | Reservados todos los derechos. Energizado por ExtendOffice, | Mapa del Sitio
Microsoft y el logotipo de Office son marcas comerciales o marcas comerciales registradas de Microsoft Corporation en los Estados Unidos y / o en otros países.
Protegido por Sectigo SSL