Note: The other languages of the website are Google-translated. Back to English

Cómo contar celdas con texto en Excel

Excel está en todas partes. Como una herramienta útil y poderosa para el análisis de datos y la documentación, a menudo la usamos en el trabajo y en la vida. En algunos casos, es posible que necesitemos comprender mejor nuestros datos para realizar un análisis de datos. En este tutorial, demostraremos varias formas de contar celdas con texto en Excel

Función COUNTIF/COUNTIFS + Carácter comodín para contar celdas con texto en Excel

Funciones SUMPRODUCT + ISTEXT para contar celdas con texto en Excel

Función CONTAR.SI para contar celdas que contienen texto específico en Excel

Cuente fácilmente las celdas que contienen texto específico con Kutools para Excel


Función COUNTIF/COUNTIFS + Carácter comodín para contar celdas con texto en Excel

Función COUNTIF para contar celdas con cualquier texto

Para contar las celdas que contienen cualquier texto, usamos el símbolo de asterisco (*) en la fórmula CONTAR.SI. El sintaxis de los Función COUNTIF es el siguiente:

=COUNTIF(range, "*")

Dado que el asterisco (*) es un comodín que coincide con cualquier secuencia de caracteres, la fórmula cuenta todas las celdas que contienen texto.

Por ejemplo, para contar celdas con texto en el rango A2:A15 como se muestra a continuación, escriba la siguiente fórmula en una celda en blanco y presione el botón Enviar Botón para obtener el resultado.

=CONTAR.SI(A2:A15, "*")

contar celda con texto 1

√ Notas:
  • Lo que no se cuenta como texto:
  1. Celdas con cualquier texto;
  2. Caracteres especiales;
  3. Números formateados como texto;
  4. Celdas visualmente en blanco que contienen una cadena vacía (=""), apóstrofe ('), espacio.
  • Lo que no se cuenta como texto:
  1. Números;
  2. Fechas;
  3. Valores lógicos de Verdadero y Falso;
  4. errores;
  5. Celdas en blanco.

En este caso, podemos entender claramente por qué hay 8 celdas con texto en la hoja de trabajo de ejemplo.

contar celda con texto 2

Función CONTAR.SI contar celdas sin texto

Para contar celdas que no contienen texto en un rango de datos, use el no es igual al operador lógico (<>) y símbolo de asterisco (*) en la fórmula CONTAR.SI. La sintaxis es la siguiente:

=COUNTIF(range, "<>*")

Debido a que no es igual al operador lógico (<>) y al símbolo de asterisco (*) significa que no es igual a ningún carácter, la fórmula cuenta las celdas sin ningún texto.

Por ejemplo, para contar celdas sin texto en el rango A2: A15, escriba la siguiente fórmula en una celda en blanco y presione el botón Enviar Botón para obtener el resultado.

=CONTAR.SI(A2:A15,"<>*")

contar celda con texto 3

Luego obtiene la cantidad de celdas que contienen valores que no son de texto.

Función COUNTIFS para contar celdas con texto excluyendo celdas visualmente en blanco

Para contar celdas con texto que excluya celdas visualmente en blanco, use el símbolo de asterisco (*), el signo de interrogación (?) y el operador lógico distinto de (<>) en la fórmula. La sintaxis es la siguiente:

=COUNTIFS(range,"*?*", range, "<> ")

A signo de interrogación (?) cerillas cualquier carácter únicoy un símbolo de asterisco (*) cerillas cualquier secuencia de caracteres. Una signo de interrogación rodeado de asteriscos (*?*) significa que al menos un carácter debe estar en la celda, por lo que la cadena vacía y el apóstrofe no se contarán.

La símbolo no igual (<>) más un espacio vacío significa no contar las celdas con el carácter de espacio.

Por ejemplo, para contar celdas con texto sin celdas visualmente en blanco en el rango A2: A15, escriba la siguiente fórmula en una celda en blanco y presione el botón Enviar Botón para obtener el resultado.

=CONTAR.SI(A2:A15,"*?*", A2:A15, "<> ")

contar celda con texto 4

Entonces puedes obtener el número de celdas que solo contiene texto visible.

√ Notas:
  1. La función COUNTIFS admite múltiples condiciones. En el ejemplo anterior, contar las celdas con texto y también excluir las celdas que contienen solo un espacio, una cadena vacía y un apóstrofo, que hacen que las celdas se vean en blanco.
  2. Si desea contar celdas con texto y no contar celdas que contienen solo un espacio, la sintaxis se convierte en = CONTAR.SI(rango,"*", rango, "<> ").

Funciones SUMPRODUCT + ISTEXT para contar celdas con texto en Excel

La segunda forma de contar celdas con valores de texto es usar el Función SUMPRODUCT junto con la Función ISTEXT. Las sintaxis es el siguiente:

=SUMPRODUCT(--ISTEXT(range))
or
=SUMPRODUCT(ISTEXT(range)*1)

La Función ISTEXT devoluciones Verdadero o falso cuando una celda contiene texto o no texto. Y el doble negativo (--) en la primera sintaxis y la operación de multiplicación en la segunda sintaxis hay dos formas de convertir VERDADERO y FALSO en los números 1 y 0.

Entonces Función SUMPRODUCT devoluciones la suma de todos los unos y ceros en el rango de búsqueda y da un conteo final.

En este caso, para contar celdas con texto en el rango A2: A15, escriba la siguiente fórmula en una celda en blanco y presione el botón Enviar Botón para obtener el resultado.

=SUMAPRODUCTO(--ESTEXTO(A2:A15))

or

=SUMAPRODUCTO(ESTEXTO(A2:A15)*1)

contar celda con texto 5

contar celda con texto 6

Independientemente de la sintaxis que utilice, el resultado devuelto será 8.

Función CONTAR.SI para contar celdas que contienen texto específico en Excel

Cuente las celdas que contienen cierto texto con una coincidencia exacta

Para realizar un coincidencia exacta de la función CONTAR.SI, simplemente ingrese el texto completo entre comillas en el segundo argumento de la fórmula. Aquí está el sintaxis:

=COUNTIF(range, "text value")

Para agregar texto en una fórmula en Excel, encerrando el texto entre comillas ("…") es necesario.

Por ejemplo, desea encontrar cuántas celdas en el rango A2: A10 contienen exactamente la palabra "bolígrafo" o "lápiz", escriba la siguiente fórmula en una celda en blanco y presione el botón Enviar Botón para obtener el resultado.

=CONTAR.SI(A2:A10, "bolígrafo")

or

=CONTAR.SI(A2:A10, "lápiz")

contar celda con texto 7

contar celda con texto 8

Cuente las celdas que contienen cierto texto con una coincidencia parcial

Para contar celdas con coincidencia parcial, coloque el texto entre dos asteriscos (*) y escríbalos entre comillas (""). Entonces le permite a COUNTIF cuente todas las celdas que contienen el texto y cualquier cosa antes y después de él. Aquí está la sintaxis:

=COUNTIF(range, "*text value*")

En este caso, suponga que desea contar cuántas celdas contienen "bolígrafo" o "lápiz" como parte de su contenido en cualquier posición, escriba la siguiente fórmula en una celda en blanco y presione el botón Enviar Botón para obtener el resultado.

=CONTAR.SI(A2:A10, "*bolígrafo*")

or

=CONTAR.SI(A2:A10, "*lápiz*")

contar celda con texto 9

contar celda con texto 10

√ Notas: COUNTIF no distingue entre mayúsculas y minúsculas.

Cuente fácilmente las celdas que contienen texto específico con Kutools para Excel

Además de usar una fórmula para contar las celdas con texto, puedes usar el Seleccionar celdas específicas utilidad de Kutools for Excel para contar y seleccionar rápidamente las celdas con texto específico en Excel.

No importa si desea contar las celdas que contienen cierto texto con un coincidencia exacta o con un coincidencia parcial, nuestro Kutools for Excel puede ayudarlo a alcanzar su objetivo fácilmente.

Kutools for Excel : con más de 300 prácticos complementos de Excel, prueba gratuita y sin límite en 30 días.

Después instalación gratuita Kutools for Excel, ¡veamos cómo funciona!

Cuente y seleccione celdas que coincidan exactamente con texto específico con Kutools

En este caso, desea encontrar cuántas celdas en el rango A2: A10 contienen exactamente el texto "bolígrafo".

contar celda con texto 11

1. Seleccione el rango desde el que desea contar las celdas que contienen texto específico.

2. Hacer clic Kutools > Selecciona > Seleccionar celdas específicas.

contar celda con texto 12

3. En el Cuadro de diálogo Seleccionar celdas específicas, necesitas:

  • Selecciona opción de celda en la Sección de tipo de selección;
  • En la sección Tipo específico, seleccione Equivale en la lista desplegable, ingrese pen en el cuadro de texto;
  • Haga clic en el OK botón. Entonces un cuadro de diálogo aparece para decirle cuántas celdas coinciden con la condición.

contar celda con texto 13

  • Haga clic en el OK en el cuadro de solicitud y todas las celdas calificadas se seleccionan en Excel al mismo tiempo.

contar celda con texto 14

Cuente y seleccione celdas que coincidan parcialmente con texto específico con Kutools

Suponga que desea contar cuántas celdas en el rango A2:A10 contienen la palabra "bolígrafo" como parte del contenido en cualquier posición. El truco es similar al anterior.

1. Seleccione el rango en el que desea contar la cantidad de celdas que contienen texto específico.

2. Hacer clic Kutools > Selecciona > Seleccionar celdas específicas.

contar celda con texto 12

3. En el Cuadro de diálogo Seleccionar celdas específicas, necesitas:

  • Selecciona opción de celda en la Sección de tipo de selección;
  • En la sección Tipo específico, seleccione contiene en la lista desplegable, entrar pluma en el cuadro de texto;
  • Haga clic en el OK botón. Entonces un cuadro de diálogo aparece para decirle cuántas celdas coinciden con la condición.

contar celda con texto 15

  • Haga clic en el OK en el cuadro de solicitud y todas las celdas calificadas se seleccionan en Excel al mismo tiempo.

contar celda con texto 16

Haga clic para descargar Kutools para Excel para una prueba gratuita de 30 días.



  • Barra de súper fórmula (edite fácilmente varias líneas de texto y fórmulas); Diseño de lectura (leer y editar fácilmente un gran número de celdas); Pegar en rango filtrado...
  • Combinar celdas / filas / columnas y conservación de datos; Contenido de celdas divididas; Combinar filas duplicadas y suma / promedio... Prevenir celdas duplicadas; Comparar rangos...
  • Seleccione Duplicado o Único Filas; Seleccionar filas en blanco (todas las celdas están vacías); Super Find y Fuzzy Find en muchos libros de trabajo; Selección aleatoria ...
  • Copia exacta Varias celdas sin cambiar la referencia de la fórmula; Crear referencias automáticamente a varias hojas; Insertar viñetas, Casillas de verificación y más ...
  • Fórmulas favoritas e insertar rápidamente, Rangos, gráficos e imágenes; Cifrar celdas con contraseña; Crear lista de distribución y enviar correos electrónicos ...
  • Extraer texto, Agregar texto, Eliminar por posición, Quitar espacio; Crear e imprimir subtotales de paginación; Convertir entre contenido de celdas y comentarios...
  • Súper filtro (guardar y aplicar esquemas de filtros a otras hojas); Orden avanzado por mes / semana / día, frecuencia y más; Filtro especial en negrita, cursiva ...
  • Combinar libros y hojas de trabajo; Combinar tablas basadas en columnas clave; Dividir datos en varias hojas; Conversión por lotes de xls, xlsx y PDF...
  • Agrupación de tablas dinámicas por número de semana, día de la semana y más ... Mostrar celdas bloqueadas y desbloqueadas por diferentes colores; Resalte las celdas que tienen fórmula / nombre...
pestaña kte 201905
  • Habilite la edición y lectura con pestañas en Word, Excel, PowerPoint, Publisher, Access, Visio y Project.
  • Abra y cree varios documentos en nuevas pestañas de la misma ventana, en lugar de en nuevas ventanas.
  • ¡Aumenta su productividad en un 50% y reduce cientos de clics del mouse todos los días!
officetab parte inferior
Comentarios (0)
Aún no hay calificaciones. ¡Sé el primero en calificar!
No hay comentarios publicados aquí todavía
Deje sus comentarios
Publicar como invitado
×
Califica esta publicación:
0  Personajes.
Ubicaciones sugeridas